Печать с кассы остатка бонусов гостя
В большинстве заведений при «бонусной» механике бонусами можно оплачивать только часть заказа. В этом случае для гостя важна информация: сколько именно бонусов у него доступно, сколько именно из них он может списать в данном конкретном заказе, сколько останется к оплате.
Вывести такую информацию можно в пречек или в отдельный документ, печатаемый по отдельной кнопке в заказе.
Вывод информации в пречек может быть нецелесообразен в случае настроенных «чеков намерения» в варианте «одновременная печать чека и пречека», т. к. для оплаты бонусами потребуется делать корректировку распечатанного чека намерения.
В этой статье описана настройка для печати отдельного документа с информацией об остатке бонусов по отдельной кнопке в окне редактирования заказа. В нашем примере бонусами можно оплатить 30% от суммы заказа.
Макет документа
Настройки → Печать → Документы и макеты → Прочее → Пользовательский макет.
Создаём новый макет, называем его «Остаток бонусов / ProBonus».
Открываем редактор макета и загружаем готовый макет по кнопке Импорт.
Внутри макета в memo34 есть скрипт, в котором прописано, какую часть заказа можно оплачивать бонусами. В данном примере бонусами можно оплачивать 30% заказа, поэтому в формуле умножение на 0.30. При необходимости эту цифру можно изменить.
Схема печати
Настройки → Печать → Схемы печати.
В используемую схему печати добавляем созданный ранее макет. Запоминаем код этого представления документа из схемы печати.
Скрипт
Сервис → Скрипты, группа «Операции».
Создаём внутри новый скрипт и называем его «Печать остатка бонусов / probonus». Пример текста скрипта:
procedure ProcessOperation1638689(Parameter: integer); begin RK7.PerformRefObject(RK7.FindItemByCode(rkrefMaketSchemeDetails,31)); end;
В данном примере 31 — это код представления документа из используемой схемы печати (не код макета).
Операция
Сервис → Операции, группа «Пользовательские операции».
Выбираем любую неиспользуемую операцию, например 16.
Меняем название и связываем с созданным ранее скриптом.
Функциональная клавиша
Настройки → Графический интерфейс → Функциональные клавиши, группа «Разные».
Создаём новую функциональную клавишу и связываем её с созданной ранее операцией.
Селектор
Настройки → Графический интерфейс → Селекторы.
Заказ → Селектор операций → Чек: Селектор операций.
Изменяем используемый селектор или, если используется предустановленный, делаем его копию и переназначаем использование. В нужную группу (например, «Доп») добавляем созданную ранее функциональную клавишу.












